Media buttons not displaying in WordPress.com Add New Post screen in Safari

I’m new to WordPress.com (though been a WordPress.org user since 2004) so forgive me if this is old news but the WordPress.com New Post dialog box doesn’t display properly in Safari (version 5.03 on OS X 10.6.6, at least).

If you look at the image below you can see that the Media buttons normally to the right of Upload/Insert are missing – in fact the only button displaying there is the Add Poll button.

WordPress.com Add New Post in Safari
WordPress.com Add New Post in Safari

Viewing the same screen in Firefox (version 3.6.13 on OS X 10.6.6) does display the buttons. Note also that under the Media menu item on the left, the Library and Add New items are correctly aligned in Firefox, but they are not in Safari.

WordPress.com Add New Post in Firefox
WordPress.com Add New Post in Firefox

One thing that the Safari screen does get right however is that it displays the Alt text for the buttons on rollover, whereas Firefox doesn’t.

One other thing I did notice (which is non-obvious, but helped by the appearance of the Alt text) is that while the media buttons don’t appear in Safari, if you rollover the space between the Upload/Insert and the Poll button, the functionality of the buttons is there, it is simply that they don’t display!!! How bizarre.

As I said at the outset, I’m new to WordPress.com, so if this is a well worn topic, forgive me – it is just new to me.

One thought on “Media buttons not displaying in WordPress.com Add New Post screen in Safari”

  1. Same problem is on my new wordpress site. i.e. while working on firefox the insert/upload line with media buttons is not shown. Kindly guide me about this problem. But what is solution. Please guide me.

Comments are closed.